Front Page Forums BioMap Export from Fleximaging

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #1195
    Tatiana Zinger


    I have two little problems, not crucial but a bit annoying.
    1)I have exported files from FlexImaging, encompassing hdr, t2m and of course img files. I can open import the img file in Biomap, I can generate some molecular images however I cannot "see" the img file, even by changing the contrast levels, and playing around with analysis->plot->point or global. Is there something I have to do to get some contrast on my img file window…just to see where I am!
    2)Besides this, the icones for the different functions on the left panel are somehow missing (texts of the functions instead), which is annoying simply because the right result windows are just half apparent, even if I increase the window size (for info, I run Biomap on a Windows 2000 system.

    Thanks in advance for your advice/help,




    1) You can test BioMap with the demodata files which you can download from this website. This should not be black if you adjust Lo/Hi values on the sliders (Hi must always be higher then Lo, but greater or equal 1!). If you can see the data correctly then BioMap works well. If not maybe you files are ‘wrong’?)
    2) If you have installed BioMap correctly with all 80 files in the biomap/icons directory it should work well and show you the correct buttons.

    Hope this solved your problems.
    So long,

    Arne Fuetterer


    regarding 1: flexImaging exports just the spectra data for BioMap. BioMap offers no intrinsic registraton of sample images, you have to co-register them manually. This is one of the user-unfriendly issues in BioMap…


    Markus Stoeckli

    1) Once you open a file, select Analysis > Plot > Point to show a spectrum for each image point. Then, either drag your mouse with the right mouse key pressed over the spectrum to select the molecular image of interest or use the middle mouse button to mark a peak of interest to calculate the corresponding molecular image.

    2) This software was not written for Windows only but for multiple OS and does therefore not use the Windows registry. Once BioMap is open, go the Edit > Defaults menu and point the BioMap path to the location where you installed BioMap to.

    3) (response to Arne) Nobody claimed BioMap to be user friendly, but once properly installed, it does offer some unique features. The correct handling of geometry information is one of them. When you import an MSI file into BioMap, the voxel size is also loaded (I don’t know if the Bruker software does actually write it into the file). Go to Edit > Header and select the Coregistration tab. Check if for the correct voxel size (in mm) or change it to you actual acquisition resolution. When you import an optical image, do the same (e.g. 300 dpi results in a voxel size of 0.085). If image areas are the same, you can directly overlay them. If not, use Tools > Geometry > Coregister to shift and rotate the images till they match.


Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.