Front Page Forums BioMap Installing BioMap on Mac OS X Tiger

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #1121
    Chris Bunch

    I am having some difficulty getting BioMap to work on an Intel Mac under OS X Tiger.

    This is what I have done:

    1. Installed X11 from Tiger OS X DVD

    2. Installed X11Update2006.pkg from Apple Website

    3. Downloaded and installed IDL Virtual Machine 6.3 for Mac OS X. The installer has put it into /Applications/rsi/idl_6.3/ along with a lot of other stuff. It also put an alias to idlvm on my desktop.

    4. Downloaded BioMap3752, unzipped it and moved the biomap folder to /usr/local (where it is owned by root).

    5. Executed sudo /usr/local/biomap/ (Note that neither /usr/local nor /usr/local/biomap are in my shell path. I also had to cd to /usr/local/biomap to get this to work). This then did what it says on the box. Note that ~/.biomap and contents are owned by root, not me. (It was necessary to change permissions to stop an ‘OPENW Error opening file Unit 103’ message (culprit file uparsc) when starting biomap.)

    So far so good. The next instruction is to "Start BioMap by executing the script ‘’". This fails. It doesn’t know where idl is. (How could it?) Various experiments with links to the did not work (anyway, shouldn’t it be Help would be appreciated here.

    6. What does work is opening the directly by double clicking, entering /usr/local/biomap/bin into the search box for .sav files, and then selecting biomap.sav. This opens biomap with the ‘Unregistered Copy – Obtained Licence…’ title.

    7. I have now obtained a licence code (thank you), copied the six lines to a file and saved it with the name licenserc in /usr/local/biomap.

    8. Now if I restart biomap (in the manner described) the title bar has not changed and therefore presumably it has not recognised the licence.

    What am I doing wrong? And also, what is the file ~/biomap for (its empty – and, no, putting licenserc in here doesn’t work either)?

    An help or insights would be most welcome.

    Many thanks

    Post edited by: bwfm, at: 2007/05/22 17:09

    Post edited by: bwfm, at: 2007/05/22 17:13

    Post edited by: bwfm, at: 2007/05/22 17:14

    Chris Bunch


    I have figured out a way of launching this from the command line, but now I get a bus error:

    theodora:~ cb$ /Applications/rsi/idl_6.3/bin/idl -rt=/usr/local/biomap/bin/biomap.sav
    IDL Version 6.3, Mac OS X (darwin ppc m32). (c) 2006, Research Systems, Inc.

    % Restored file: IDLRTMAIN.
    pBMT_SetupStructures: Initializing structures…
    % PBMT_READPARAMETER: Reading /Users/cb/.biomap/uparsrc
    % PLIB_READSTRUCTDATA: Error occured, exiting:Variable is undefined: NAME.
    % PBMT_READPARAMETER: Reading /Users/cb/.biomap/infrc
    % PLIB_READSTRUCTDATA: Error occured, exiting:Variable is undefined: NAME.
    % PBMT_READPARAMETER: Reading /Users/cb/.biomap/systemrc
    % PBMT_READPARAMETER: Reading /Users/cb/.biomap/winrc
    % PLIB_READSTRUCTDATA: Type of tag was not recognized
    % PLIB_READSTRUCTDATA: Error occured, exiting:Variable is undefined: NAME.
    Bus error
    theodora:~ cb$

    Any ideas, anyone…?

    Markus Stoeckli

    All right, this might be an obvious question, but did you copy the setting files to this location?


    Chris Bunch

    My settings files are in ~/.biomap (ie not ~/biomap)

    Markus Stoeckli

    So that would be in /Users/cb/.biomap/ ?


    Chris Bunch

    yes, assuming I am logged in as cb (which I am)

    Markus Stoeckli

    OK, so far my quick guess… Just to be sure, if you remove the files from this current location, do you get the same error? Do you have permission to edit these files?

    There are not too many mac users for BioMap out there and I’m not one of them. Let’s see if we can get some wisdom from the pros…


    Markus Stoeckli

    The following message was received from Akos:

    Dear Peter,

    Few days ago I could manage to install BioMap on my Mac (OS X 10.5) and it works fine ever since. I think the trouble is the licenserc file that seems to best in the biomap system directory (/.biomap).

    I installed the BioMap into my user directory and modified the uparsrc-linux-mac file also in the /.biomap directory.
    Now, my question is how familiar you are with the Mac OS structure (I was not for sure) to be able to find hidden directories and files? The reason is that ALL system directories and files are hidden by default on Macs and there is no simple switch to show and hide them like on PCs in the Folder options. When I realized this I made two plug-ins with the Automator following the description on this site:
    Then I could easily find the biomap system dir (/.biomap) and copy the licenserc file into it.

    However, it still did not work for me for the reason that the licenserc file was not correct!
    First I got the message from the Webmaster without any attachment only written the code as text that looked like this:

    TYPE =3D 13571
    ID =3D 725341
    EXP =3D 108075823
    MRI =3D 0
    MSI =3D 67388375
    WIP =3

    Following discussion with Markus he pinpointed that this is not a correct content of a licenserc file and suggested to remove all “3D”s. At this point I have to add that I created this file with TextEdit and removed its extension. So, it became like this:

    TYPE = 13571
    ID = 725341
    EXP = 108075823
    MRI = 0
    MSI = 67388375
    WIP = 0

    After that it still did not work however.
    Then I got the idea to apply for the code again. This time I got the file as attachment as well but to my surprise it looked differently opened by TextEdit (first line was empty!):

    âÌzCz…TYPE = 13571
    ID = 725341
    EXP = 108075823
    MRI =
    MSI = 67388375
    WIP =

    And it did not work but it did after the first (empty) and the garbage in the second line was removed!!!

    In conclusion, my recommendation is to play around with the licenserc file and get it in right format and BioMap will run nicely on Mac.

    Good luck!



    There was a problem with encoding the attachment, which has been solved by now.


Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.